Drupal Sistem Gereksinimleri

Etiketler: 

Merhaba ziyaretçilerimiz, bu yazımızda size günümüzün en popüler İçerik Yönetim Sistem'lerinden biri olan Drupal'i kullanmak için gerekli olan sistem gereksinimlerini sunuyoruz.


Kullanılacak Web Sunucu
:
 

Apache (Önerilen):

  • Drupal İçerik Yönetim Sistemi Unix/Linux veya Windows üzerinde Apache 1.3 veya Apache 2.x ile çalışır.Ancak Drupal'in geliştirme sürecinin büyük bir kısmı Apache üzerinde yapıldığı için , bu sistem üzerinde daha çok topluluk tecrübesi ve test imkanı mevcuttur.

  • Temiz url(Uniform Resource Locater) lere izin vermek için Apache 'mod_rewrite' genişletmesini (extension) kullanabilirsiniz. 

Microsoft IIS

  • Drupal core IIS5 veya IIS6  üzerinde  PHP düzgün şekilde konfigüre edilmiş ise çalışabilir.  Fakat Microsoft'un destek hayat döngüsü açısından bakıldığında IIS6 veya IIS7 kullanılması daha çok önerilir.

  • Temiz url'ler elde etmek için 3.parti yazılımlar kullanmanız gerekmektedir.Eğer IIS7 kullanıyorsanız Microsoft'un IIS için URL Rewrite modülünü kullanmayı deneyebilirsiniz. Microsoft URL Rewrite Module for IIS 7.0 CTP1.

  • Drupal'ı  IIS7 üzerinde fastcgi ile kullanacaksanız Hotfix kb954946  hotfix'ini yüklemeniz veya paket içinde hotfix eklenmesini beklemelisiniz. (önerilen)

     

Drupal web sunucu bağımsız geliştirilmektedir, ancak burada listenenlerin dışında ya limitli ya da başarılı olduğuna dair çok az geri dönüş mevcuttur.

Drupal yüklemesinin toplam dosya boyutu sitenize neleri eklediğinize bağlı olarak değişmekle beraber, Drupal core dosyaları tek başına yaklaşık olarak  2-3 MB  (dekompres edildikten sonra) yer kaplamaktadır.  Kesin boyutu Drupal'ın kullanmakta olduğunuz spesifik versiyonuna bağlıdır.

Benzer Makaleler

Programciyim.com
Mayıs 4, 2010, 11:14 am
Programciyim.com
Kasım 2, 2008, 8:19 pm